PCリンクスでは、パソコンの設定・修理から組込み機器の受託開発まで承ります。

 

PacketiX VPN 4.0 のベータ版(RC1)でNATトラバーサルを試す

3回目の今回は、PacketiX VPN 4.0 ベータ版で追加された、NATトラバーサル(UDPホールパンチング)機能を試します。

新たなLinuxサーバに、PacketiX VPN 4.0 ベータ版をインストールします。この時、ルーターの設定は、一切、変更しない状態でVPN接続試験を実施します。
注意点は、必ず、PacketiX VPN Client を使用して、VPN接続を行うことです。
※OpenVPNクライアントやWindows標準搭載のVPN接続クライアントからは、NATトラバーサルを使用したVPN接続を行うことが出来ません。また、設置環境によっては、まれ(5%くらい)に、VPN接続ができない場合があるようです。そのような場合は、最終手段として「VPN Azure クラウドサービス機能」を使用します。

※当方の設置環境では、NATトラバーサルが正しく機能し、ルーター設定を一切変更することなく、VPN接続を行うことが可能でした。

packetix VPN 4.0 RC1 12 300x231 PacketiX VPN 4.0 でNAT T

NATトラバーサルとVPN Azure の詳細は、こちら 新機能 – 接続性の向上、ファイアウォールの貫通 を、ご参照ください。

 

NATトラバーサルを使用してVPN接続

クライアントPCからのVPN接続は、EVO3Dのテザリング機能を利用して、インターネットへ接続します。

PacketiX VPN 4.0 ベータ版では、インストールを完了した状態で、NATトラバーサル(以降はNAT-Tと記述)機能は有効となっています。

PacketiX NAT T 01 254x300 PacketiX VPN 4.0 でNAT T

ダイナミックDNSの設定も有効となっています。
固定IPアドレスを取得すること無しに、VPNサーバを使用することが可能です。(ドメインの取得も必要ありません)

PacketiX NAT T 02 300x226 PacketiX VPN 4.0 でNAT T

ルーターの設定は、何も変更を実施しない状態で、NAT-Tを無効にして、VPN接続を行います。
当然、VPN接続を行うことができませんが、これは正常な動作となります。
※ルーターの先にPacketiX VPN 4.0 をインストールしたサーバがありますが、そのサーバと通信できません。

PacketiX NAT T 03 300x240 PacketiX VPN 4.0 でNAT T

次に、NAT-T機能を有効にして、PacketiX VPN Client から、VPN接続を行います。
※必ず、PacketiX vpn Client を使用する必要があります。

PacketiX NAT T 04 300x237 PacketiX VPN 4.0 でNAT T

接続状況を確認し、使用中のプロトコルが[VPN over UDP with NAT-T(IPv4)] と表示されていることを確認します。

PacketiX NAT T 061 300x256 PacketiX VPN 4.0 でNAT T

仮想LANカード(VPN Client Adapter-VPN)の設定情報を確認します。

PacketiX NAT T 07 211x300 PacketiX VPN 4.0 でNAT T

PacketiX VPN 4.0 ベータ版をインストールしたLinuxサーバへpingを飛ばし、応答が返ることを確認します。

PacketiX NAT T 081 300x159 PacketiX VPN 4.0 でNAT T

今度は、接続先のネットワーク上のPCから、VPN接続中のクライアントPCへpingを飛ばし、応答が返ることを確認します。

PacketiX NAT T 09 300x182 PacketiX VPN 4.0 でNAT T

次に、VPN接続先のネットワーク上のWindowsPCへリモートデスクトップ接続を行います。

PacketiX NAT T 10 300x235 PacketiX VPN 4.0 でNAT T

最後に、Windows上でファイル共有が可能なことを確認します。

PacketiX NAT T 11 300x144 PacketiX VPN 4.0 でNAT T

 

ダイナミックDNSでVPN接続

Packetix VPN 4.0 ベータ版では、新たに、[ダイナミックDNS]機能を搭載しています。

ダイナミックDNS機能は、インストールした状態で、有効となっています。
固定グローバルIPアドレスを取得していない場合は、”お財布にやさしい機能” だと思います。

通常、プロバイダと普通に契約した場合は、動的なグローバルIPアドレスが割り当てられます。
このIPアドレスは、ルーターなどを再起動すると、変化してしまいますので、その都度、ホスト名とグローバルIPアドレスの対応(紐付け)を更新しなければなりませんが、その役目をダイナミックDNSが担います。
※更新は、「1 分から 2 分の間隔で自身の IP アドレスの変化を監視している」とのことです。(ソフトイーサ社のサポート担当者からの回答より)

PacketiX NAT T 12 300x219 PacketiX VPN 4.0 でNAT T

当方の環境は、固定グローバルIPアドレスでサーバを運用しており、ダイナミックDNSは不要ですが、この機能を利用したVPN接続でも、問題なくVPN接続を行うことが可能でした。
※接続先の設定が固定IPアドレスで指定するか、ホスト名を指定してVPN接続するかの違いがあるだけです。

PacketiX NAT T 13 300x256 PacketiX VPN 4.0 でNAT T

以上で、「PacketiX VPN 4.0 のベータ版(RC1)でNATトラバーサルを試す」を終了します。

 

PacketiX VPN 4.0 のベータ版(RC1)でOpenVPNを試す

2回目の今回は、PacketiX VPN 4.0 ベータ版で新規に追加された[OpenVPN互換機能]を試します。

Windows,Mac,Linuxを採用したPC向けに、VPN接続用クライアントソフウェアが、無償提供されています。
OpenVPNでは、用途に応じて、L3(IPルーティング)モードとL2(Ethernetブリッジ)モードの2通りの動作モードを使用することができます。WindowsPCでは、VPN接続用のプロトコルはいろいろ選択可能ですが、Macでは、使用できるプロトコルが限られますので、OpenVPN互換機能はMac向け?かな….と思います。

 

OpenVPNクライアントのインストール

VPN接続用のクライアントソフトウェアをインストールします。日本語対応しており、とても使いやすいVPN接続クライアントです。

インストール手順は、こちらの OpenVPN Clientのインストール をご参照ください。

 

OpenVPNクライアントの初期設定

OpenVPNクライアントのインストールが完了したら、VPN接続先等の初期設定を行います。

PacketiX VPN 4.0 ベータ版では、VPNサーバ管理マネージャ上で、サンプル設定ファイルを作成することが出来ますので、設定は、非常に簡単です。

OpenVPN 01 300x244 PacketiX VPN 4.0 でOpenVPN

作成されたサンプル設定ファイル(openvpn_l3.ovpnとopenvpn_l2.ovpn)は、接続先設定(remoteで指定するvpn接続先情報)を修正する必要があります。ダイナミックDNSを有効にしている場合は、修正は必要ありませんが、固定のグローバルIPアドレスで運用している場合は、マニュアルでの修正が必要となります。

###############################################################################
# OpenVPN 2.0 Sample Configuration File
# for PacketiX VPN / SoftEther VPN Server
# 
(省略)
# remote ローカルIPアドレス 1194
remote 61.206.xxx.xxx 1194

修正が完了したら、ディレクトリごとFDやUSBメモリなどに保存します。

OpenVPN 02 300x147 PacketiX VPN 4.0 でOpenVPN

作成したサンプル設定ファイルを使用して、OpenVPNクライアントを設定します。

OpenVPN 03 240x300 PacketiX VPN 4.0 でOpenVPN

[プロファイルのインポート]の[ローカルファイル]を選択し、[インポート]をクリックします。

OpenVPN 04 240x300 PacketiX VPN 4.0 でOpenVPN

openvpn_l3.ovpnを選択すると、同一ディレクトリ内にあるセキュリティ証明書も一緒に読み込まれます。

OpenVPN 05 300x147 PacketiX VPN 4.0 でOpenVPN

名前を変更したい場合は、適当な名前に変更します。OKであれば保存ボタンをクリックします。

OpenVPN 06 240x300 PacketiX VPN 4.0 でOpenVPN

接続プロファイルにL3(IPルーティング)モード接続が追加されました。

OpenVPN 07 240x300 PacketiX VPN 4.0 でOpenVPN

同様な手順でL2(Ethernetブリッジ)モード接続を追加します。L2モード時は、openvpn_l2.ovpnを指定します。

OpenVPN 08 240x300 PacketiX VPN 4.0 でOpenVPN

 

ルーターのポート開放とWINS設定

OpenVPN互換接続機能を使用する場合は、ルーターのポート開放(ポートフォワーディング)が必要となります。
当方の環境では、ヤマハのルーター(RTX1100)を使用していますので、フィルタ設定も変更します。また、WINSサーバのアドレス設定も行うようにします。

# OpenVPN対応
ip pp secure filter in xx 76 xx dynamic xxx
ip filter 76 pass * サーバのIPアドレス udp * 1194
nat descriptor masquerade static 1 4 サーバのIPアドレス udp 1194

#DHCPでクライアントに渡すためのWINSサーバのIPアドレスを設定する
wins server WINSサーバのIPアドレス

 

L3(IPルーティング)モード指定時のファイル共有対応

L3モードでは、ブロードキャストによる名前解決がうまく出来ないため、以下のいずれかの方法で名前解決を行う必要があります。IPアドレスを、直接指定してアクセスすることも可能です。

  • WINSサーバを用意する
  • hosts(lmhosts)ファイルを記述する
  • DNSサーバを用意する

当方の試験環境では、LinuxOS上でsambaサーバを稼動させていますので、sambaのWINSサーバ機能を使用することにしました。
WINSサーバのアドレスの配布は、ルーターのDHCPサーバで行うように、ルーター設定の項目で設定済みです。

 

L3(IPルーティング)モードでVPN接続

OpenVPNでの接続準備が整いましたので、WindowsPCを使用してリモートVPN接続を行います。この場合は、L3(IPルーティング)を使用することが、推奨されています。(readmeより)
当初は、DHCPサーバで配布するWINSサーバのアドレスが、うまくクライアントPCに設定できないBugがありましたが、Build 8708で修正されました。

VPN接続は、EVO3Dのテザリングを利用して、Wi-Fi接続したノートPCから、VPN接続を行います。

OpenVPN 10 240x300 PacketiX VPN 4.0 でOpenVPN

VPN接続を開始すると、ユーザ名とパスワードの入力を求められます。

OpenVPN 11 240x300 PacketiX VPN 4.0 でOpenVPN

IPアドレス等が割り当てられます。

OpenVPN 12 240x300 PacketiX VPN 4.0 でOpenVPN

VPN接続が完了すると、接続情報が表示されます。

OpenVPN 13 240x300 PacketiX VPN 4.0 でOpenVPN

仮想LANカード(TAP-Win32 Adapter OAS)の詳細情報を確認し、WINSサーバの設定を確認します。

OpenVPN 15 245x300 PacketiX VPN 4.0 でOpenVPN

VPN接続クライアントPCから接続先のLinuxサーバへpingを飛ばし、応答が返ることを確認します。

OpenVPN 16 300x151 PacketiX VPN 4.0 でOpenVPN

ネットワーク上の他のPCから、VPN接続クライアントPCへpingを飛ばし、応答が返ることを確認します。

OpenVPN 17 300x206 PacketiX VPN 4.0 でOpenVPN

次に、ネットワーク上のWindowsPCへリモートデスクトップ接続を行います。

OpenVPN 18 300x188 PacketiX VPN 4.0 でOpenVPN

最後に、Windows上でファイル共有が可能なことを確認します。

OpenVPN 19 300x125 PacketiX VPN 4.0 でOpenVPN

 

L2(Ethernetブリッジ)モードでVPN接続

L2モードは、「遠隔拠点に設置する、VPNブリッジ用のPC上で動作するOpenVPNは、L2(Ethernetブリッジ)用の接続設定を使用してください」と、readmeファイルに記述されています。
L2モードでのリモートVPN接続は、推奨されていませんが、VPN接続は問題なく動作可能でした。

L3(IPルーティング)モードで問題となった、ブロードキャストによる名前解決も正しく機能しましたので、こちらの接続がお勧めかも知れません。

OpenVPN 20 240x300 PacketiX VPN 4.0 でOpenVPN

VPN接続が完了すると、接続情報が表示されます。

OpenVPN 21 240x300 PacketiX VPN 4.0 でOpenVPN

仮想LANカード(TAP-Win32 Adapter OAS)の詳細情報を確認し、WINSサーバの設定を確認します。

OpenVPN 23 240x300 PacketiX VPN 4.0 でOpenVPN

VPN接続クライアントPCから接続先のLinuxサーバへpingを飛ばし、応答が返ることを確認します。

OpenVPN 24 300x171 PacketiX VPN 4.0 でOpenVPN

ネットワーク上の他のPCから、VPN接続クライアントPCへpingを飛ばし、応答が返ることを確認します。

OpenVPN 25 300x190 PacketiX VPN 4.0 でOpenVPN

次に、ネットワーク上のWindowsPCへリモートデスクトップ接続を行います。

OpenVPN 26 300x188 PacketiX VPN 4.0 でOpenVPN

最後に、Windows上でファイル共有が可能なことを確認します。

OpenVPN 27 300x125 PacketiX VPN 4.0 でOpenVPN

以上で、「PacketiX VPN 4.0 のベータ版(RC1)でOpenVPNを試す」を終了します。

 

PacketiX VPN 4.0 のベータ版(RC1)を試す

2012年11月26日 ソフトイーサ社からPacketiX VPN 4.0 ベータ版(RC1)がリリースされました。

当方は、2012年1月に配布が開始されたPacketiX VPN 3.0 ベータ版(L2TP/IPsec対応版)からのユーザで、今回のメジャーアップデートを心待ちにしていた1人でもあります。

PacketiX VPN 4.0 では新たに、L2TP/IPsec,OpenVPN,MS-SSTP,L2TPv3,EtherIP プロトコルがサポートされました。また、VPN接続をより簡単に行えるようにするために、「ダイナミックDNS」、「NATトラバーサル(UDPホールパンチング)」、「VPN Azureクラウドサービス」などの各種機能を新たに搭載しています。

Packetix VPN 4.0 RC1 の詳細は、こちらの PacketiX VPN 4.0 のベータ版 (RC1) を公開  を参照ください。

packetix VPN 4.0 RC1 00 300x120 PacketiX VPN 4.0 RC1を試す

PacketiX VPN 4.0 べータ版(RC1) で追加された機能を中心に、簡単な評価レポートをお届けします。
1回目の今回は、追加された機能の概要とPacketix VPN Clientを使用したVPN接続を試します。

 

PacketiX VPN 4.0 ベータ版(RC1)のインストール

当方は、Linuxサーバ上にPacketiX VPN Serverをインストールしています。

インストール手順は、こちらの PacketiX VPN Server(β2)を使う をご参照ください。
ダウンロードするファイル指定を変更するだけで、同様な手順でインストールすることが出来ます。

PacketiX VPN 4.0 ベータ版では、初期状態で[ダイナミックDNS]の機能が、有効となっています。
ダイナミックDNSを使用すると、プロバイダが割当てる動的IPアドレス(ドメインの取得も無用)で、VPNサーバを運用することが可能となります。コストを抑えて、簡単にVPN環境を導入できるようになっています。

packetix VPN 4.0 RC1 03 300x225 PacketiX VPN 4.0 RC1を試す

今回のVPN接続試験では、新しく追加された機能のうち[ダイナミックDNS]と[NATトラバーサル]機能を無効化して、VPN接続を行います。

こうすることで、今まで評価していたPacketiX VPN 3.0 ベータ2と、機能的にほぼ同じ動作となるはずですので、動作確認がしやすくなるメリットがあります。
※ベータ版ですので、Bugが潜んでいる可能性がありますので、慎重に接続試験を進めていきます。

変更は、WindowsPC上に、vpn_server.config ファイルを保存して、適当なテキストエディタで該当箇所を修正します。修正ファイルを読み込むことで変更が反映されます。

packetix VPN 4.0 RC1 04 300x259 PacketiX VPN 4.0 RC1を試す

WindowsPC上で、vpn_server.configファイルの記述を2箇所 “false” から “true” に修正します。

  • bool Disabled true
  • bool DisableNatTraversal true
# Software Configuration File
# 
# You can edit this file when the program is not working.
# 
declare root
{
	uint ConfigRevision 91
	bool IPsecMessageDisplayed true

	declare DDnsClient
	{
		bool Disabled true
(省略)
	declare ServerConfiguration
	{
		uint64 AutoDeleteCheckDiskFreeSpaceMin 104857600
		uint AutoSaveConfigSpan 300
		bool BackupConfigOnlyWhenModified true
		string CipherName RC4-MD5
		uint CurrentBuild 8708
		bool DisableDeadLockCheck false
		bool DisableDosProction false
		bool DisableIntelAesAcceleration false
		bool DisableIPv6Listener false
		bool DisableNatTraversal true
(省略)

修正したvpn_server.configファイルをインポートして読み込みします。設定が完了すると、サーバ管理マネージャが自動的に終了します。

サーバ管理マネージャを再起動すると、ダイナミックDNS設定の項目が薄く表示されるようになり、選択できないようになりました。VPN Azure設定も、同時に無効化されるようです。

packetix VPN 4.0 RC1 05 300x225 PacketiX VPN 4.0 RC1を試す

※NATトラバーサル機能が無効化されたかどうかは、[configファイルの編集]表示から、現在の設定値を確認します。

 

PacketiX VPN 4.0 ベータ版(RC1)の対応プロトコルとルーター対応

PacketiX VPN 4.0で新たに追加されたプロトコル(L2TP/IPsec,OpenVPN,MS-SSTP)を使用するためには、ルーターのポートを開放する必要があります。

VPN接続に使用するプロトコルに合わせて、ルーターの設定を変更します。

packetix VPN 4.0 RC1 12 300x231 PacketiX VPN 4.0 RC1を試す

当方の環境では、ヤマハのVPNルーター(RTX1100)を使用しており、下記のコマンドでポート開放を行っています。詳細は、ご使用のルーターの取説をご覧ください。

nat descriptor masquerade static 1 3 サーバのIPアドレス tcp https
nat descriptor masquerade static 1 5 サーバのIPアドレス esp
nat descriptor masquerade static 1 6 サーバのIPアドレス udp 500
nat descriptor masquerade static 1 7 サーバのIPアドレス udp 4500

PacketiX VPN 4.0ベータ版で追加された「NATトラバーサル(NAT-T)」機能を使用すると、面倒なルーターのポート開放を行わなくても、VPN接続が可能となります。ただし、下記のような制限がありますので、注意が必要です。

  • ルーターの仕様により、NATトラバーサルを使用しても、VPN接続できないことがあります。
  • クライアントPCでは、PacketiX VPN Clientを、必ず、使用する必要があります。
  • iPhoneなどの携帯端末からVPN接続を行う場合は、ポート開放を行う必要があります。

下表に、各OSの対応プロトコルとルーターのポート開放の対応表を示します。
L2TP/IPsecの採用が無難な選択ですが、設置環境に合わせて、オールマイティな対応が可能と思われます。

プロトコル
(クライアント)
iOS/Android
(携帯端末)
Windows
(PC)
MacOS X
(PC)
Linux
(PC)
ルータ対応
(ポート開放)
備  考
PPTP gre
tcp/1723
セキュリティーホール有り
※使用中止が推奨されている
L2TP/IPsec esp
udp/500
udp/4500
各OSに標準搭載
※Linuxは自分でインストール
MS-SSTP tcp/443 Windows Vista以降標準
※WindowsXPは未対応
VPN Azureに対応
OpenVPN udp/1194
tcp/1194
オープンソース
動作モードを選択可能
・L3(IPルーティング)モード
・L2(Ethernetブリッジ)モード
SoftEther独自
(Packetix VPN Client)
tcp/443
udp/動的
ソフトイーサ独自プロトコル
Layer2で接続
NATトラバーサルに対応
VPN Azureに対応

 

Packetix VPN ClietnからVPN接続

最初に、WindowsPCにPacketiX VPN Clientをインストールします。
インストール手順は、こちらの PacketiX VPN Clientを使う をご参照ください。

PacketiX VPN 4.0 では、NATトラバーサル(UDPホールパンチング)機能が動作して、ルーターのポート開放を行わない状態で、VPN接続を行うことが出来ます。
ソフトイーサ社によると、NAT越えの成功率は、95.7%くらいだそうです。すごいですね。

PacketiX VPNのインストールが初めての場合は、ルーターのポート開放を行わない状態で、VPN接続を行うことをお勧めします。すんなり、VPN接続が行える可能性が高いです。
※ただし、NATトラバーサル機能が使えるのは、PacketiX VPN Clientから接続する場合に限られます。
iPhoneやAndroidを採用した携帯端末からVPN接続を行う場合は、ルーターの対応が必要となります。

クライアントPCから接続をクリックすると、VPN接続が開始され、[接続完了]と表示されれば、OKです。

packetix VPN 4.0 RC1 01 300x237 PacketiX VPN 4.0 RC1を試す

[接続状況の表示]をクリックすると、VPN接続情報の詳細を確認することが出来ます。
今回は、ルーターのポートを開放していますので、プロトコルは[Standard TCP/IP(IPv4)]と表示されています。

packetix VPN 4.0 RC1 02 300x256 PacketiX VPN 4.0 RC1を試す

WindowsXP標準のVPN接続クライアントからVPN接続

次に、WindowsXP標準のVPN接続クライアントでL2TP/IPsecプロトコルを指定して、VPN接続を行います。

packetix VPN 4.0 RC1 06 300x279 PacketiX VPN 4.0 RC1を試す

VPN接続時のステータスを示します。

packetix VPN 4.0 RC1 07 280x300 PacketiX VPN 4.0 RC1を試す

 

VPN接続が完了したら、接続試験を実施します。双方向でpingが通じることを確認します。また、リモートデスクトップ接続動作やWindowsファイルの共有などが行えることを確認します。

最初に、クライアントPCからPacketiX VPN 4.0をインストールしたサーバへpingを打ち、応答が返ることを確認します。

packetix VPN 4.0 RC1 08 300x159 PacketiX VPN 4.0 RC1を試す

今度は、接続先のネットワーク上のPCからVPN接続を行っているクライアントPCへpingを打ち、同様に応答が返ることを確認します。

packetix VPN 4.0 RC1 09 300x182 PacketiX VPN 4.0 RC1を試す

次に、VPN接続先のネットワーク上のPCへ、リモートデスクトップ接続を行い、アクセスできることを確認します。

packetix VPN 4.0 RC1 10 300x188 PacketiX VPN 4.0 RC1を試す

最後に、VPN接続先のネットワーク上でファイル共有(Windows上での共有やsambaでの共有など)ができることを確認します。

packetix VPN 4.0 RC1 11 300x179 PacketiX VPN 4.0 RC1を試す

以上で、「PacketiX VPN 4.0 のベータ版(RC1)を試す」を終了します。

 

NEC IX2005でミラーリング機能を使う

IX2005のポートミラーリング機能を使用して、フレッツフォンVP2000のパケットを観察します。

ミラーリング機能は、特定のHUBポートを「ミラーリングポート」もしくは「モニタポート」に指定し、モニタポートを通過するトラフィックをコピーしてミラーリングポートから出力する機能です。ミラーリング機能を使用することで、パケットキャプチャによるトラブル解析などを簡単に行えるようになります。

パケットキャプチャを行うソフトウェアは、ネットワークプロトコルアナライザのWireSharkを使用します。
非常に有用なソフトウェアですが、無償で使用することができます(GNU General Public License

WireShark 01 300x244 IX2005でミラーリング機能を使う

 

IX2005のポートミラーリング設定

IX2005の設定を変更して、ポートミラーリング機能を使えるように設定を追加します。
※前回のPPPoEの設定で、すでに下記の設定は、実施済みですが、FastEthernet1.0 のプライベートIPアドレスは、RTX1100と競合しないように、適当なアドレスに変更する必要があります。(パケットキャプチャ時)

今回は、SW-HUBのポート3をモニタしたい機器を接続するモニタポート、ポート4をパケットキャプチャ用のPCを接続するミラーポートに設定します。

Router# enable-config

interface FastEthernet1.0
  ip address 192.168.0.2/24

device FastEthernet1
  port 3 mirror-port 4 both
  exit

 

フレッツフォンのパケットをキャプチャ

最新版のWireSharkをダウンロードして、PCへインストールします。

パケットをキャプチャしたい機器をSW-HUBのポート3、WireSharkをインストールしたPCをポート4へ接続します。ポート1、またはポート2を使用して、既存のローカルネットワークに接続します。

今回は、フレッツフォンVP2000の電源投入時のHTTPパケットをキャプチャしてみます。
フレッツフォンでは、電源投入時にひかり電話ルーターのSIPサーバと通信を行い、ユーザID,内線番号,パスワードなどの情報をフレッツフォンに自動的にセットします。
従いまして、通常のSIP電話機のような細かな設定を、マニュアル操作で行う必要はありません。(マニュアル設定は、仕様上出来ないようになっています)

フレッツフォンVP2000から、ひかり電話ルータ(SIPサーバ)へ、情報がPOSTされています。

VP2000 01 300x285 IX2005でミラーリング機能を使う

ひかり電話ルーター(SIPサーバ)から、フレッツフォンへSIP設定等の情報が返されます。
このやり取りで、SIPサーバへフレッツフォンが自動的に登録され、ひかり電話として使用可能となります。

VP2000 02 300x285 IX2005でミラーリング機能を使う

フレッツフォンで117へ通話時のSIPパケットを示します。

VP2000 032 300x300 IX2005でミラーリング機能を使う

 

以上で、「NEC IX2005でミラーリング機能を使う」を終了します。

 

NEC IX2005でPPPoE接続

NECのIPv6対応高速アクセスルーターであるUNIVERGE IX2005の初期設定を行います。

この製品は、旧モデル(GbE非対応)ですが、現行機種です。ちなみに、GbE対応品はIX2105となります。
当方は、WireSharkでポートミラーリングを行うためと、RTX1100が故障した時の代替機として利用する目的で、オークションで入手しました。

業務用ルーターにふさわしく、非常にシンプルで、信頼性が高そうな設計がなされています。

ix2005 PCB1 300x167 NEC IX2005でPPPoE接続

IX2005を使用した場合のネットワーク構成図を以下に示します。
※PR-200NEは、PPPoEブリッジモードで使用し、ひかり電話機能のみを使用するするようにします。

ix2005 01 300x243 NEC IX2005でPPPoE接続

 

コンソールケーブルの作成(変換ケーブル)

IX2005の初期設定は、コンソール端子に専用ケーブルを接続して、ターミナルプログラムからルーターの初期設定を行う必要があります。

あいにく、コンソールケーブルの手持ちが無かったので、変換ケーブルを作成しました。RJ45コネクタの信号をDサブ(プラグ)コネクタへ変換しているだけのケーブルです。

RJ45 DSUB Cable 01 300x135 NEC IX2005でPPPoE接続

この変換ケーブルを使用すると、YAMAHAのVPNルーター用のコンソールケーブル(クロスケーブル)をそのまま利用できるようになります。IX2005とCentreCOM AR550Sで動作確認し、問題なく動作しています。

RJ45 DSUB Cable 02 300x139 NEC IX2005でPPPoE接続

 コンソールケーブルの仕様は、アライドテレシス社の下記の資料を参考にしました。

CentreCOM VT-Kit2 RS-232ケーブル(RJ-45/D-Sub 9ピン)

 

ターミナルソフトウェアの起動

コンソールケーブルを接続して、ターミナルソフトウェア(TeraTerm)を起動して、通信ポート設定を行います。

tera term 01 300x275 NEC IX2005でPPPoE接続

 

IX2005の設定を初期化

最初に、設定の初期化を行います。
電源を投入し、Loading: ################## が表示されているところで、CTRL+C を入力します。

NEC Bootstrap Software
Copyright (c) NEC Corporation 2001-2011. All rights reserved.

%BOOT-INFO: Trying flash load, exec-image [ix2005-ms-8.7.22.ldc].
Loading: ##################
NEC Bootstrap Software, Version 9.1
Copyright (c) NEC Corporation 2001-2011. All rights reserved.
boot[0]> cc
Enter Y to clear startup configuration: y
% Startup configuration is cleared.

NEC Bootstrap Software, Version 9.1
Copyright (c) NEC Corporation 2001-2011. All rights reserved.
boot[0]> dc
Enter Y to clear default configuration: y
% Default configuration is cleared.

NEC Bootstrap Software, Version 9.1
Copyright (c) NEC Corporation 2001-2011. All rights reserved.
boot[0]> b

NEC Bootstrap Software
Copyright (c) NEC Corporation 2001-2011. All rights reserved.

%BOOT-INFO: Trying flash load, exec-image [ix2005-ms-8.7.22.ldc].
Loading: ################################################################ [OK]


Starting at 0x20000
(略)

初期化が完了したらIX2005を再起動して、Diagnosticが正常に終了することを確認します。

NEC Diagnostic Software
Copyright (c) NEC Corporation 2001-2011. All rights reserved.

%DIAG-INFO: Starting System POST(Power On Self Test)

          DRAM TEST 1: Pass
          DRAM TEST 2: Pass
           NVRAM TEST: Pass
             CPU TEST: Pass
             PLD TEST: Pass
             FE0 TEST: Pass
  FE1(SW-HUB)1-4 TEST: Pass
        SECURITY TEST: Pass
   1.5 VOLTAGE STATUS: 1.466V Pass
   2.5 VOLTAGE STATUS: 2.483V Pass
   3.3 VOLTAGE STATUS: 3.251V Pass
   TEMPERATURE STATUS: +44.0degC Pass

NEC Bootstrap Software
Copyright (c) NEC Corporation 2001-2011. All rights reserved.

%BOOT-INFO: Trying flash load, exec-image [ix2005-ms-8.7.22.ldc].
Loading: ################################################################ [OK]


Starting at 0x20000

Configuring router subsystems (before IDB proc): done.
Constructing IDB(Interface Database): done.
Configuring router subsystems (after IDB proc): done.
Initializing router subsystems: done.
Starting router subsystems: done.

All router subsystems coming up.

NEC Portable Internetwork Core Operating System Software
Copyright Notices:
Copyright (c) NEC Corporation 2001-2011. All rights reserved.
Copyright (c) 1985-1998 OpenROUTE Networks, Inc.
Copyright (c) 1984-1987, 1989 J. Noel Chiappa.

 

IX2005のPPPoE接続設定

IX2005の初期化が完了したので、プライベートアドレス設定,httpサーバ設定とPPPoE接続設定を行います。

最初に、configを有効にします。

Router# enable-config
Enter configuration commands, one per line. End with CNTL/Z.

次に、設定を行います。下記の設定をカット&ペーストして、ルーターに流し込みます。

Router(config)# 
! #############################
! PPPoE Settings 2012.07.18
! #############################

timezone +09 00
hostname [ix2005]

ntp ip enable
ntp server 210.173.160.27
ntp retry 3
ntp interval 3600

logging buffered 131072
logging subsystem all notice
logging timestamp datetime
syslog facility local5
syslog ip host 192.168.0.26

username UserID password xxxxxxxxxxxxxxxx administrator

ip dhcp enable
ip access-list telnet-source permit ip src 192.168.0.0/24 dest any
ip access-list web_console permit ip src any dest 192.168.0.0/24
ip ufs-cache enable

ip directed-broadcast

telnet-server ip enable
telnet-server ip access-list telnet-source

http-server username admin
http-server ip access-list web_console
http-server ip enable

ppp profile web_fastethernet0.1
  authentication myname isp接続情報
  authentication password isp接続情報 パスワード

ip dhcp profile sw-hub
  assignable-range 192.168.0.230 192.168.0.253
 subnet-mask 255.255.255.0
  default-gateway 192.168.0.1
  lease-time 86400
  dns-server 192.168.0.26 192.168.0.1
  exit

device FastEthernet0
device FastEthernet1
  port 3 mirror-port 4 both
  exit

ip route default FastEthernet0.1

proxy-dns ip enable
proxy-dns server 203.141.128.35 priority 254
proxy-dns server 203.141.128.33 priority 254

interface FastEthernet0.0
  ip address 192.168.1.254/24
  no shutdown

interface FastEthernet1.0
  ip address 192.168.0.1/24
  ip dhcp binding sw-hub
  no shutdown

interface FastEthernet0.1
  description Interlink
  encapsulation pppoe
  auto-connect
  ppp binding web_fastethernet0.1
  ip address ipcp
  ip mtu 1454
  ip tcp adjust-mss auto
  ip napt enable

! ip napt static FastEthernet0.1 udp 500
! ip napt service http 192.168.0.26 none tcp 80
  ip napt service smtp 192.168.0.26 none tcp 25

! PacketiX VPN Serever
  ip napt static 192.168.0.26 udp 500
  ip napt static 192.168.0.26 udp 4500
  ip napt static 192.168.0.26 tcp 1723

! PacketiX VPN Server GRE(47),ESP(50)
  ip napt static 192.168.0.26 47
  ip napt static 192.168.0.26 50


  no shutdown

interface Loopback0.0
  no ip address

interface Null0.0
  no ip address
  exit

設定をスタートコンフィグへ保存します。

Router(config)# write memory
Building configuration...
% Warning: do NOT enter CNTL/Z while saving to avoid config corruption. 

 

Webブラウザからアクセス

設定が完了したので、ネットワーク上のPCのWebブラウザから、IX2005の管理画面にアクセスしてみます。

FastEthernet1.0のプライベートアドレス(192.168.0.1)をブラウザに入力して、ルーターの管理画面にアクセスします。

ix2005 web 01 276x300 NEC IX2005でPPPoE接続

右上のログイン実行ボタンを押すと、ユーザ名/パスワードを入力画面が現れますので、ユーザ名とパスワードを入力して、OKボタンをクリックします。

ix2005 web 021 300x107 NEC IX2005でPPPoE接続

ログインすると、Web GUI上で各種設定を行うが出来ます。
ヤマハのRTX1100同様、すべての設定を行う機能はありませんので、「設定の確認に使える程度」と割り切って使用するほうが良いようです。

ix2005 web 031 242x300 NEC IX2005でPPPoE接続

<PPPoE接続情報を確認します

ix2005 web 04 300x295 NEC IX2005でPPPoE接続

 

以上で、「NEC IX2005でPPPoE接続」を終了します。

    
3 / 13« 先頭...234...10...最後 »